Empathy con supporto a Adium Theme (su Jaunty)

Ieri hanno inserito il supporto ai temi di Adium nel branch master di Empathy :)

Proviamolo su Jaunty.

  1. Installare la solita robaccia di base per compilare i programmi (git e bluild-essential)
  2. Installare tutte le dipendenze di empathy in un solo colpo:
    sudo apt-get build-dep empathy

  3. Installare la libreria webkit (serve appunto per la compatibilità con Adium):
    sudo apt-get install libwebkit-dev

  4. Scaricare e installare dal ppa di telepathy l’ultima versione dei pacchetti:

  5. Clonare il branch di empathy in sviluppo:
     git clone git://git.gnome.org/empathy

  6. Compilare il tutto e installare:
    ./autogen --prefix=/usr        ## o quello che volete
    make
    sudo make install              ## o anche checkinstall, come preferite...

  7. Fatto? (cit.) Bene, ora scaricare e scompattare da qualche parte uno dei temi funzionali che potete trovare in questa pagina: Empathy/Themes (io ho usato RenkooNaked).

  8. Lanciare il nuovo Empathy, recarsi in Modifica -> Prefrenze -> Temi e selezionare nella ComboBox la voce «Adium»

  9. Infine fare uso del FileChooserDialog per selezionare la directory nella quale avete scompattato il tema.

Bene, se avete culo¹ dovreste visualizzare un risultato tipo questo:

Note:
¹: non tanto per la vostra compilazione, quanto se le cose che ho scritto sono effettivamente giuste.
²: il link oscurato nell’immagine riguarda ovviamente l’ultimo delirio di Villa Certosa: un matrimonio fittizio fra Berlusconi e una giovane Lady.

7 pensieri su “Empathy con supporto a Adium Theme (su Jaunty)

  1. sono su ubuntu 9.10 ho seguito tutta la procedura più volte ma dopo la compilazione non riesco a creare un account (nel mio caso di hotmail) quando tento di salvarlo non lo salva e vado oltre mi dice nessun protocollo installato ma io ho tutto a posto per quanto riguarda telepathy compreso telepathy-butter-fly
    Se mi potete aiutare ve ne sarei grato

    • Ciao…

      Su Ubuntu 9.10 Empathy è già abbastanza aggiornato per avere il supporto ai temi di Adium. Non devi far altro che installarlo (se l’hai tolto):
      sudo apt-get installa empathy

      Successivamente scarica un tema di Adium e scompattalo nella cartella:
      ~/.local/share/adium/message-styles/

      Infine lancia Empathy e cerca nelle Preferenze le impostazioni relative all’aspetto dell’applicazione.

      Qui maggiori info: Empathy Themes

      Ciao!

  2. Grazie per la tua rapida risposta ho seguito già il tuo consiglio, comunque avevo trovato la soluzione una strana gestione del portachiavi bloccava l’inserimento di un nuovo account, ma comunque è una versione troppo instabile, riavviando il pc il problema si ripresenta e devo rifare pulizia, in più la lista dei contatti in linea e non non si vedeva. Conclusione sperimenterò nuove release quando saranno più stabili per il momento uso la 2.28.1. Grazie

Rispondi